1006. Sign In and Sign Out (25)-----Java

题目内容
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
题目分析
1.找出进入最小的时间所对应的名字和出去最大的时间所对应的名字。
2.不需要保存输入的数据
代码

//不保存

import java.util.Scanner;


public class Main2 {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        String name1="",name2="";
        int min = 24*3600+60*60+60,max = -1,index1=-1,index2=-1;
        for (int i = 0; i <n; i++) {
            String name = sc.next();
            String sign_in = sc.next();
            String sign_out = sc.next();
            String[] in = sign_in.split(":");
            String[] out = sign_out.split(":");
            int signin = Integer.valueOf(in[0])*3600 + Integer.valueOf(in[1])*60+ Integer.valueOf(in[2]);
            int signout = Integer.valueOf(out[0])*3600 + Integer.valueOf(out[1])*60+ Integer.valueOf(out[2]);
            if(min>signin){
                min = signin;
                name1 = name;
            }
            if(max<signout){
                max = signout;
                name2 = name;
            }
        }
        System.out.println(name1+" "+name2);
    }

}
//保存

import java.util.Scanner;

class persons{
    public 
        String name;
        int sign_in;
        int sign_out;
        persons(){

        }
        persons(String name,int in,int out){
            this.name = name;
            sign_in = in;
            sign_out = out;
        }
}
public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        persons people[] = new persons[n];
        for (int i = 0; i < people.length; i++) {
            String name = sc.next();
            String sign_in = sc.next();
            String sign_out = sc.next();
            String[] in = sign_in.split(":");
            String[] out = sign_out.split(":");
            int signin = Integer.valueOf(in[0])*3600 + Integer.valueOf(in[1])*60+ Integer.valueOf(in[2]);
            int signout = Integer.valueOf(out[0])*3600 + Integer.valueOf(out[1])*60+ Integer.valueOf(out[2]);
            people[i] = new persons(name, signin, signout);
        }
        int min = 24*3600+60*60+60,max = -1,index1=-1,index2=-1;
        for (int i = 0; i < people.length; i++) {
            if(min>people[i].sign_in){
                min = people[i].sign_in;
                index1 = i;
            }
            if(max<people[i].sign_out){
                max = people[i].sign_out;
                index2 = i;
            }
        }
        System.out.println(people[index1].name+" "+people[index2].name);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值