PAT A1079. Total Sales of Supply Chain (25)

原文链接: PAT A1079. Total Sales of Supply Chain (25)

上一篇: PAT A1102. Invert a Binary Tree (25)

下一篇: PAT A1090. Highest Price in Supply Chain (25)

1079. Total Sales of Supply Chain (25)

https://www.patest.cn/contests/pat-a-practise/1079

时间限制

250 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意:给一棵树,在树根出货物的价格为p,然后从根结点开始每往下走一层,该层的货物价格将会在父亲结点的价格上增加r%,给出每个叶结点的货物量,求他们的价格之和
分析:树的遍历,可以采用dfs或者bfs两种方法。
采用dfs,建立结构体数组保存每一个结点的孩子结点的下标,如果没有孩子结点,就保存这个叶子结点的data(销售的量)。深度优先遍历的递归出口,即当前下标的结点没有孩子结点的时候,就把ans += data(货物量)* pow(1 + r, depth)计算货物量*价格引起的涨幅百分比。如果有孩子结点,就dfs深度优先遍历每一个孩子结点,并且在当前depth层数的基础上+1。最后输出ans * p(销售价格),即总价格

记住将r化为百分数.....

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
using namespace std;

struct Node {
	double data;
	vector<int> child;
};

vector<Node> tree;	//静态存放数的各个节点
double ans = 0.0;	//存放结果 
double p, r;		//价格和比率 
					//从根节点开始,逐层遍历 
void dfs(int root, int level) {
	if (tree[root].child.size() == 0) {
		ans += tree[root].data*pow(1 + r, level);
		return;
	}

	for (int i = 0; i < tree[root].child.size(); i++) {
		dfs(tree[root].child[i], level + 1);
	}
}
int main(int argc, char *argv[]) {
	int n;

	scanf("%d %lf %lf", &n, &p, &r);
	r /= 100;			//记住化为百分比啊啊啊啊啊 
	tree.resize(n);
	for (int i = 0; i < n; i++) {
		int cnt;
		scanf("%d", &cnt);
		if (cnt == 0)
			scanf("%lf", &tree[i].data);
		else {
			for (int k = 0; k < cnt; k++) {
				int t;
				scanf("%d", &t);
				tree[i].child.push_back(t);
			}
		}
	}

/*
	for(int i=0;i<n;i++)
		for(int j=0;j<tree[i].child.size();j++)
			printf("%d%c",tree[i].child[j],j==tree[i].child.size()-1?'\n':' ');
	*/
	dfs(0, 0);	//从根节点开始,由第0层遍历
	printf("%.1f", ans*p);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值