【PAT】1029. Median (25)

题目描述

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

翻译:给你一个包括N个数的升序数列S,中位数就是在数列中间的数字。举个例子,S1{11, 12, 13, 14} 的中位数是12,S2{9, 10, 15, 16, 17} 的中位数是15。两个数列的中位数被定义为包括两个数列所有数字的升序数列的中位数。举个例子,S1和S2的中位数是13。

INPUT FORMAT

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

翻译:每个输入文件包含一组测试数据。每组输入数据包括2行,每行包括一个数列的信息。对于每个数列,第一个正整数N(<=1000000) 代表这个数列的长度。接下来的N个正整数有空格隔开。数据保证所有整数在long int 范围内。

OUTPUT FORMAT

For each test case you should output the median of the two given sequences in a line.

翻译:对于每组测试数据,你需要输出两个数列的中位数。


Sample Input

4 11 12 13 14
5 9 10 15 16 17

Sample Output

13


解题思路

这道题可以用算法中两链表合并来解,不过我试了一下sort,结果直接过了。。。。读入记得用scanf,否则会超时。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
vector<long long int> v;
int main(){
    int N;
    for(int i=0;i<2;i++){
        scanf("%d",&N);
        long long int temp;
        for(int j=0;j<N;j++){
            scanf("%lld",&temp);
            v.push_back(temp);
        }
    }
    sort(v.begin(),v.end());
    long long int mid=0;
    mid=v[(v.size()-1)/2];
    printf("%lld\n",mid);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值