PAT(甲级)1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

 简析:这道题主要是将数字进行固定小数位的科学表示法,如果两个表示法一样就输出YES和对应的表示法,不然输出NO,然后输出各自的表示。

       虽然表面是数字,但是它会给出过界的数字,所以需要通过字符串来操作,不然会出错。主要就是算出主要的部分,把无关的0和小数点去掉。最后输出的时候再加上“0.”,多退少补‘0’。

#include<iostream>
#include<string>
#include<cmath>
using namespace std;
string cntl(string s,int& n,int m)
{
    int k = 0;
    while(s.length() > 0 && s[0] == '0')
        s.erase(s.begin());
    if(s[0] == '.')
    {
        s.erase(s.begin());
        while (s.length() > 0 && s[0] == '0')
        {
            s.erase(s.begin());
            n--;
        }
    }else{
        
        while(k < s.length() && s[k] != '.')
        {
            k++;
            n++;
        }
        if(k < s.length())
            s.erase(s.begin() + k);
    }
    if(s.length() == 0)
        n = 0;
    int num = 0;
    k = 0;
    string res;
    while(num < m)
    {
        if(s.length() > k)
            res += s[k++];
        else
            res += '0';
        num++;
    }
    return res;
}
int main()
{
    string s1, s2, s3, s4;
    int n, e1 = 0, e2 = 0;
    cin >> n >> s1 >> s2;
    s3 = cntl(s1, e1, n);
    s4 = cntl(s2, e2, n);
    if(s3 == s4 && e1 == e2)
        cout << "YES 0." << s3 << "*10^" << e1 << endl;
    else
        cout << "NO 0." << s3 << "*10^" << e1 << "  0." << s4 << "*10^" << e2 ;
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值