Farthest Nodes in a Tree(树的直径)

 Farthest Nodes in a Tree

Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

先一次搜索搜索到最远的端点,然后再从这个端点搜索整个树,即为树中最远的距离,就是树的直径,两次BFS。
#include<cstdio>
#include<cstring>
#include<queue> 
using namespace std;
const int MAXN = 30000 + 10;

struct Edge 
{
    int from, to, val, next;
};
Edge edge[MAXN * 2];
int head[MAXN];  //每个节点的头"指针" 
int edgenum;     //总边数 
int ans;   //记录最后结果 
int Tnode; //记录s-t的端点 
int dist[MAXN];//以该节点结尾的最长路 
bool vis[MAXN];//标记节点是否被访问过 
int n;
void addEdge(int u, int v, int w) 
{
    edge[edgenum].from = u;
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}
void BFS(int s) 
{
    memset(dist, 0, sizeof(dist));
	memset(vis, false, sizeof(vis));
    queue<int>Q;
	Q.push(s); 
	vis[s] = true; 
	ans = 0;
    while(!Q.empty()) 
	{
        int u = Q.front();
		Q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next) 
		{
            int v=edge[i].to;
            if(!vis[v]) 
			{
                if(dist[v]<dist[u]+edge[i].val) 				
                    dist[v]=dist[u]+edge[i].val;                
                vis[v] = true;
                Q.push(v);
            }
        }
    }
    for(int i = 0; i < n; i++) 
	{
        if(ans < dist[i]) 
		{
            ans = dist[i];
            Tnode = i;
        }
    }
}
int main()
{
	int t,kcase=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
	    memset(head, -1, sizeof(head));
		edgenum = 0;
		for(int i=1;i<=n-1;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addEdge(u,v,w);
			addEdge(v,u,w);
		}
		BFS(0);
		BFS(Tnode);
		printf("Case %d: %d\n",kcase++,ans);
	}			
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值