【Light oj 1094 Farthest Nodes in a Tree】

Farthest Nodes in a Tree

Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output
For each case, print the case number and the maximum distance.

Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100
Case 2: 80

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define K 30011
using namespace std;
struct node{
    int from,to,val,next;
};
node st[K*2];
int head[K],edg;
int dis[K];
bool vis[K];
int ans,cot,n,test=1;
void init()
{
    edg=0;
    memset(head,-1,sizeof(head));
}
void addEdge(int x, int y,int z)
{
    node E ={x,y,z,head[x]};
    st[edg]=E;
    head[x]=edg++;
}
void getMap()
{
    int a,b,c;
    for(int i=1;i<n;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        a++,b++;
        addEdge(a,b,c);
        addEdge(b,a,c);
    }
}
void BFS(int fx)
{
    queue <int> q;
    memset(dis,0,sizeof(dis));
    memset(vis,false,sizeof(vis));
    vis[fx]=true;
    ans=0;
    cot=fx;
    q.push(fx);
    while(!q.empty())
    {
        int w=q.front();
        q.pop();
        for(int i=head[w];i!=-1;i=st[i].next)
        {
            node E=st[i];
            if(!vis[E.to]&&dis[E.to]<dis[w]+E.val)
            {
                vis[E.to]=true;
                dis[E.to]=dis[w]+E.val;
                if(dis[E.to]>ans)
                {
                ans=dis[E.to];
                cot=E.to;
                }
                q.push(E.to);
            }
        }
    }
}
void solve()
{
    BFS(1);
    BFS(cot);
    printf("Case %d: %d\n",test++,ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        init();
        getMap();
        solve();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值