E - Farthest Nodes in a Tree



Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80







Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80



经典的求树的直径

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
# define M 30030
struct  node{
int f,to,val,next;
}a[M*2];
int head[M];
int s;    //总边数 
void  init()
{
memset(head,-1,sizeof(head));
s=0;
}
void st(int u,int v,int w)
{
a[st].f=u;
a[st].to=v;
a[st].val=w;
a[st].next=head[u];
head[u]=s++;
}
int ans;       //记录最后结果 
int tnode;         //记录S-T的端点 
int dist[M];     //以该节点结尾的最长路 
bool vis[M];     //标记该节点是否被访问过 
int n;
void bfs(int x)
{
memset(dist,0,sizeof(dist));
memset(vis,false,sizeof(vis));
queue<int> q;
q.push(x);vis[x]=true;dist[x]=0;ans=0;
while(!empty())
{
int u=q.front();q.pop();
for(int i=head[u];i!=-1;i=node[i].next)
{
int v=node[i].to;
if(!vis[v])
{
if(dist[v]<dist[u]+node[i].val)
{
dsit[v]=dist[u]+node[i].val;
}
vis[v]=true;
q.push(v);
}
}
}
for(int i=0;i<n;i++){
if(ans<dist[i]){
ans=dist[i];
tnode=i;
}
}
}
int  main()
{
int t,k=1;;
scanf("%d",&t);
while(t--)
{
int n;
int u,v,w;
scanf("%d",&n);
for(int i=0;i<n-1;i++){
scanf("%d%d%d",&u,&v,&w);
st(u,v,w);
st(v,u,w);
}
bfs(0);
bfs(tnode);init();
printf("case %d: %d",k++,ans);

}
return 0;
}

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值