Fibsieve`s Fantabulous Birthday
Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.
Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.
The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.
(The numbers in the grids stand for the time when the corresponding cell lights up)
In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.
Input
Input starts with an integer T (≤ 200), denoting the number of test cases.
Each case will contain an integer S (1 ≤ S ≤ 10^15) which stands for the time.
Output
For each case you have to print the case number and two numbers (x, y), the column and the row number.
Sample Input
3
8
20
25
Sample Output
Case 1: 2 3
Case 2: 5 4
Case 3: 1 5
题意:按图中的规律,给你一个点,让你求它的坐标。
由图中信息可得,n^2(其中n=1,2,3......)的坐标在边缘地带,当n能整出2时,它的坐标为(n,1),这时就知道规律了。
给你一个数,先开平方,求出它在那个范围,然后再计算。另外在n为奇偶时分开考虑。
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int t;
int flag=1;
scanf("%d",&t);
while(t--)
{
long long s;
long long ans;
scanf("%lld",&s);
long long n,x,y;
n=sqrt(s);
if(n%2==0) //当n为偶数时
{
y=1;
x=n;
if(s-n*n==0)
{
printf("Case %d: %lld %lld\n",flag++,x,y);
continue;
}
ans=s-n*n;
if(ans<=n+1)
{
y=ans;
x++;
}
else
{
ans=ans-(n+1);
x=x+1-ans;
y=n+1;
}
printf("Case %d: %lld %lld\n",flag++,x,y);
}
else
{
x=1;
y=n;
if(s-n*n==0)
{
printf("Case %d: %lld %lld\n",flag++,x,y);
continue;
}
ans=s-n*n;
if(ans<=n+1)
{
x=ans;
y++;
}
else
{
ans=ans-(n+1);
y=y+1-ans;
x=n+1;
}
printf("Case %d: %lld %lld\n",flag++,x,y);
}
}
return 0;
}