Humble Numbers

M - Humble Numbers
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence 
 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 
 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. 
 

Sample Input

     
     
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output

     
     
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
#include<stdio.h>
#include<set>
#include<math.h>
using namespace std;
int main()
{
	set<long long >s;//直接暴力,枚举2,3,5,7的幂,然后乘,存到set里,自动排序。 
	set<long long >::iterator it;
	long long a[6000],t,t2,t3,t4,t5;
	int n,i,j,k,d;
	s.insert(1);
	for(i=0;pow(2,i)<=2e9;i++)
	for(j=0;pow(3,j)<=2e9;j++)
	{
	if(pow(3,j)*pow(2,i)>2e9)
	break;
	for(k=0;pow(5,k)<=2e9;k++)
	{
	if(pow(2,i)*pow(3,j)*pow(5,k)>2e9)
	break;
	for(d=0;pow(7,d)<=2e9;d++)
	{
		t=pow(2,i)*pow(3,j)*pow(5,k)*pow(7,d);
		if(t>2e9)
		break;
		s.insert(t);
	}
}
}
	a[0]=0;
	for(i=1,it=s.begin();it!=s.end();i++,it++)
		a[i]=*it;
	while(~scanf("%d",&n)&&n!=0)
	{
		if(n%100!=11&&n%10==1)
		printf("The %dst humble number is %lld.\n",n,a[n]);//巨坑啊,英语序数词末尾是11,12,13也是th ,坑不坑!!! 
		else if(n%100!=12&&n%10==2)
		printf("The %dnd humble number is %lld.\n",n,a[n]);
		else if(n%100!=13&&n%10==3)
		printf("The %drd humble number is %lld.\n",n,a[n]);
		else 
		printf("The %dth humble number is %lld.\n",n,a[n]);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值