1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

题目思路为多叉树,我的思路使用了较为复杂的形式实现。可以考虑使用变长数组vector(给自己留了去学一下这个的任务)

自用测试用例

9 5

01 2 02 03

02 2 04 05

03 1 06

04 2 07 08

07 1 09

#include <stdio.h>
 #include <stdlib.h>
 #include <math.h>
 #define maxsize 100
struct Node
{
    int no;
    int level;
    struct Node *parent,*next,*child;
};
void setle(int a,struct Node* p){
    p->level=a;
    if(p->next)
        setle(a,p->next);
    return;
}
int main()
{
    int np,nnlp,i=0,j=0;
    int a=0,b=0,c=0;
    int le=0,sum=0,max=0;
    scanf("%d%d",&np,&nnlp);
    j=np-nnlp;
    struct Node* nodelist[maxsize];
    struct Node* p;
    for(i=0;i<maxsize;i++)
    {
        nodelist[i]=(struct Node *)malloc(sizeof(struct Node));
        nodelist[i]->parent=NULL;nodelist[i]->next=NULL;nodelist[i]->child=NULL;
        nodelist[i]->no=-1;nodelist[i]->level=-1;
    }
    nodelist[1]->level=0;
    for(i=0;i<nnlp;i++)
    {
        scanf("%d%d",&a,&b);
        nodelist[a]->no=a;
        p=nodelist[a];
        for(j=0;j<b;j++)
        {
            scanf("%d",&c);
            if(j==0)
            {
                p->child=nodelist[c];
                p=p->child;
            }
            else
            {
                p->next=nodelist[c];
                p=p->next;
            }
        }
    }
    for(i=1;i<=np;i++)
    {
        le=nodelist[i]->level+1;
        if(le>max) max=le;
        p=nodelist[i];
        if(p->child)
            {setle(le,p->child);}
    }
    for(j=0;j<max;j++)
    {
        sum=0;
        for(i=0;i<=np;i++)
        {
            if((nodelist[i]->level==j)&&(nodelist[i]->child==NULL))
                sum++;
        }
        if(j==0) printf("%d",sum);
        else  printf(" %d",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值