PAT 甲级 1004

  1. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

# 解题思路
# 先根据读取的内容建树,这个树不是严格意义上的树,只需要把每个非叶节点的内容存到一个字典或者数组中。理论上知道根,就能遍历整棵树
# tmap是记录非叶节点的的字典
# 建完树后从根开始用深度优先搜索遍历,深度记录在record数组中
# 打印的思路,首先N-M可以得到叶子节点的数量
# 从低往高遍历record,累计,到累计值为叶子节点数量时,停止循环
record = [0 for i in range(101)]
tmap = {}

def dfs(id, level):
    if not id in tmap:
        record[level] += 1
        return
    for cid in tmap[id]:
        dfs(cid,level+1)

if __name__ == '__main__':
    N,M = map(int, input().split())
    for i in range(M):
        line = input().split() # 读取数据

        rid = int(line[0])
        K = int(line[1])

        tmap[rid] = []

        for cid in line[2:]:
            cid = int(cid)
            tmap[rid].append(cid)

    dfs(1,0)

    cnt = record[0]
    cle = N-M
    result = str(record[0])
    for i in range(1,101):
        if cnt >= cle:
            break
        result += " " + str(record[i])
        cnt += record[i]

    print(result)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值