PATA1004之BFS求解

问题描述

PAT A1004 Counting Leaves (30分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree,
and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children.
For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line. The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

思路

  • 本题考查的是树的层次遍历,题目给定结点个数、非叶子结点及其子节点,需要我们求出每一层叶子结点的个数。
  • 可以使用BFS搜索的框架对树中的结点进行遍历
  • 使用一个队列que存储待访问的结点,用vector数组存储结点及其子节点,用pair容器来绑定结点及其层数,用一个数组nums来保存每一层中的叶子结点个数

代码

#include<stdio.h>
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
typedef pair<int,int> P;	//第一个值表示结点,第二个值表示层数 
const int maxn=101; 
vector<int>nodes[maxn];//用于保存每个结点及其子节点 
int num_nodes,non_leaf;	//n用于表示结点个数,m用于表示非叶子结点的个数
int nums[maxn]={0};	//用于存储每一层叶子结点的个数 
int level=0;	//表示当前层 
void init()
{
	scanf("%d %d",&num_nodes,&non_leaf);
	for(int i=0;i<non_leaf;i++)
	{
		int root,k;
		scanf("%d %d",&root,&k);
		for(int j=0;j<k;j++)
		{
			int child;
			scanf("%d",&child);
			nodes[root].push_back(child);	
		} 
	}
}
void BFS()	//采用BFS搜索的方法进行层次遍历 
{
	queue<P> que;
	que.push(P(1,0));	//首先将根节点放入队列中
	while(!que.empty())
	{
		P p=que.front();
		que.pop();
		int len=nodes[p.first].size();
		if(len==0)	nums[p.second]++;
		else
		{
			for(int i=0;i<len;i++)
			{
				que.push(P(nodes[p.first][i],p.second+1));//注意是P而不是p,否则会编译出错	
			}
			level=max(level,p.second+1);	//更新层数 
		}
	}
} 
void print()//打印
{
	for(int i=0;i<=level;i++)
	{
		printf("%d",nums[i]);
		if(i!=level)	printf(" ");
	}	
} 
int main()
{
	init();
	BFS();
	print();
	return 0;	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值