第四题 UVA455 Periodic Strings

116 篇文章 1 订阅

UVA455 Periodic Strings

A character string is said to have period k if it can be formed by concatenating one or more repetitions
of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed
by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
char s[82];
int main() {
	int T; scanf("%d",&T);
	while(T--) {
		scanf("%s",s+1);
		int len = strlen(s+1);
		for(int i=1;i<=len;i++) {
			if(len%i != 0) continue;
			bool f=1;
			for(int j=i+1;j<=len;j++) {
				if(s[j]!=s[ j%i==0 ? i : j%i]){ f=0; break; }
			}
			if(f){
				printf("%d\n",i);
				break;
			}
		}
		if(T) printf("\n");
	}
	return 0;
} 

枚举循环节 需注意 j%i==0 ? i : j%i 这一块的处理 我当时这一点小问题卡了好长时间

简直了,UVa这格式卡的真难受,两个答案之间输出空行

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值