UVa 455 Periodic Strings【最小循环子串】




A character string is said to have period  k  if it can be formed by concatenating one or more repetitions of another string of length  k . For example, the string " abcabcabcabc " has period 3, since it is formed by 4 repetitions of the string " abc ". It also has periods 6 (two repetitions of " abcabc ") and 12 (one repetition of " abcabcabcabc ").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input.Two consecutive output are separated by a blank line.【结尾没有回车】

Sample Input

1

HoHoHo

Sample Output

2


#include <stdio.h>
#include <string.h>

char str[105];
int main(){
	int n,len,i,k;
	scanf("%d",&n);
	while(n--){
		memset(str,'\0',sizeof(str));
		scanf("%s",str); 
		
		len=strlen(str);
		
		for(i=1;i<=len;i++){	//该字符串可能没有循环字子串,那么就是他本身,i=len 
			if(len%i==0)		//最小子串一定是可以被len整除的 
			{
				for(k=i;k<len;k++){
					if(str[k]!=str[k%i])
						break;
				}
				if(k==len){
					printf("%d\n",i);				
					break;
				}
			} 
		}
		if(n)	printf("\n");
	}
	return 0; 
}





注意比较巧妙的是


len%i==0   //最小子串一定是可以被len整除的

if(str[k]!=str[k%i])

下标从0开始,k从i开始依次与前i个字母进行比较



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值