第十七题 UVA10129 Play on Words

116 篇文章 1 订阅

PDF
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve
it to open that doors. Because there is no other way to open the doors, the puzzle is very important
for us.
There is a large number of magnetic plates on every door. Every plate has one word written on
it. The plates must be arranged into a sequence in such a way that every word begins with the same
letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’.
Your task is to write a computer program that will read the list of words and determine whether it
is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to
open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing a single integer number N that indicates the number of
plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will
appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the first letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is
possible.’. Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

终于复习到我当时就最喜欢的图论部分了,(树 那玩意可比图难多了,,,,,,个人向)
给出每个单词其实就一个从首字母向末尾字母的“桥”,判断整张图是否存在 欧拉道路

欧拉:

欧拉道路的定义:从某个点出发,经过每条边一次且仅一次的道路
欧拉回路的定义:从某个点出发,经过每条边一次且仅一次并且回到起点的道路

欧拉回路:连通图 && 图中所有点的度数都是偶数
欧拉道路:连通图 && 奇数度定顶点不超过两个

/*
形成欧拉道路的条件有2:
1: 整个图连通 (DFS判断) 
2:图中所有点的出度 等于 入度,或者 只有两个奇度点 并且一个点的入度比出度大一(终点)
一个点的出度比入度大一(起点) 

*/ 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Maxn 100003
using namespace std;
int in[Maxn],out[Maxn];
int G[30][30],vis[30]; 

void dfs(int x) {
	vis[x] = 1;
	for(int i=0; i<26; i++) 
		if(G[x][i] && !vis[i]) dfs(i);
}

int main () {
	char s[1005];
	int n,T; scanf("%d",&T);
	while(T--) {
		scanf("%d",&n);
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		memset(G,0,sizeof(G));
		memset(vis,1,sizeof(vis));
		for(int i=1; i<=n; i++) {
			scanf("%s",s+1);
			int len = strlen(s + 1);
			int u = s[1] - 'a';
			int v = s[len] - 'a';
			G[u][v] = 1; out[u]++; in[v]++;
			vis[u] = vis[v] = 0;
		}
		int p = 0,cnt = 0,cnt1 = 0,cnt2 = 0,flag = 0;;
		for(int i=0; i<26; i++) {
			if(in[i] == out[i]) continue;
			if(in[i] == out[i] + 1) cnt1++;// 终点 
			else if(in[i] == out[i] - 1) cnt2++;// 起点
				 else { flag = 1; break;  }
		}
		if(flag) { printf("The door cannot be opened.\n"); continue; }
		if((cnt1 == 1 && cnt2 == 1) || (cnt1 == 0 && cnt2 == 0)) flag = 1;//flag=1 出入度满足了初步条件 
		
		dfs(p);
		for(int i=0; i<26; i++) 
			if(!vis[i]) flag = 0;// 检验底图是否连通 
		if(flag) printf("Ordering is possible.\n");
		else printf("The door cannot be opened.\n");
	} 
	
	
	return 0;
}

参考链接 : 中国大学Mooc 离散数学 刘铎

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值