POJ 3481 Double Queue Treap 带详细注释

今天吴永辉老师讲的是平衡树,怎么这就讲平衡树了,😣😣😣😣🤐
没办法,听的也是云里雾里,自己补吧

Double Queue

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20706 Accepted: 8849
Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:
0 The system needs to stop serving
1 K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list
Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.
Input
Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.
Output
For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.
Sample Input
2
1 20 14
1 30 3
2
1 10 99
3
2
2
0
Sample Output
0
20
30
10
0
Source
Southeastern Europe 2007

题目大意:
银行服务的每个顾客都有优先级和编号,银行可以有三种操作

  • 给优先级最大的顾客办理业务
  • 给优先级最小的顾客办理业务
  • 向当前队列插入新的顾客(她的编号和优先级)
  • 银行可以时刻保证当前队列里的顾客的编号和优先级都没有重复
    题目分析:
    直接构建Treap,每个节点插入一个val(优先级)一个r(随机函数值)以及一个id(顾客的编号)
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<ctime>
#include<cstdio>

using namespace std;
struct Node {
	Node *ch[2];
	int rank,id,val;
	Node (int val,int id) : val(val),id(id) {
		rank = rand();
		ch[0] = ch[1] = NULL;
	}
	int cmp(int x) {
		if(x == val) return -1;
		else return x < val ? 0 : 1;
	}
};


inline void Rotate(Node* &cur,int d) { // 1表示右旋 
	Node *k = cur -> ch[d^1];
	cur -> ch[d^1] = k -> ch[d];
	k -> ch[d] = cur;
	cur = k;// 以后写代码的时候 就认准d==1  按照右旋写 
}

inline int Find_Max(Node *cur) {
	if(cur -> ch[1] == NULL) { printf("%d\n",cur -> id); return cur -> val; }
	else return Find_Max(cur -> ch[1]);
}

void Insert(Node* &cur,int id,int val) {
	if(cur == NULL) { cur = new Node(val,id); }
	else {
		int d = val < cur -> val  ? 0 : 1;
		Insert(cur -> ch[d],id,val);
		if(cur -> ch[d] -> rank > cur -> rank) Rotate(cur , d^1);
	}
}

inline int Find_Min(Node *cur) {
	while(cur -> ch[0] != NULL) {
		cur = cur -> ch[0]; 
	}
	printf("%d\n", cur -> id);
	return cur -> val;
}

void Remove(Node *&cur,int val) {
	int d = cur -> cmp(val);
	if(d == -1) {// 删除当前节点 
		Node *u = cur;
		if(cur -> ch[0] == NULL || cur -> ch[1] == NULL){
			// 只有一个儿子的情况   直接取而代之 
			if(cur -> ch[0] == NULL) cur = cur -> ch[1];// 左儿子是空的 有儿子取而代之 
			else cur = cur -> ch[0];
			delete u;// 不删除并不影响数据结构的正确性 只是为了防止炸内存
		}else {// 左右子树都有的情况 
		// 策略是把他旋转中可以直接进行删除的节点 
			int d2 = cur -> ch[0] -> rank < cur -> ch[1] -> rank ? 0 : 1;
			// 左边小就左旋    
			Rotate(cur,d2);
			Remove(cur -> ch[d2],val);// 当前节点转到了d2方向去 
		}
	}
	else if(d == 0) Remove(cur -> ch[0],val);
	else if(d == 1) Remove(cur -> ch[1],val);
}

int main(int argc,char* argv[]) {
	int op;
	Node *root = NULL; 
	while(scanf("%d",&op) == 1 && op) {
		if(op == 1) {
			int id,val; scanf("%d %d",&id,&val);
			Insert(root,id,val);
		}else if(op == 2) {
			if(root == NULL) { printf("0\n"); continue; }
			int v = Find_Max(root);
			Remove(root,v);
		}else if(op == 3) {
			if(root == NULL) { printf("0\n"); continue; }
			int v = Find_Min(root);
			Remove(root,v);
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值