POJ 1442 Black Box Treap 查询第K大

95 篇文章 1 订阅
37 篇文章 0 订阅

Black Box

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17311 Accepted: 7041
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:
Example 1
N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer arrays:

  1. A(1), A(2), …, A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
  2. u(1), u(2), …, u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, … and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
    The Black Box algorithm supposes that natural number sequence u(1), u(2), …, u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u§ <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), …, A(u§) sequence.
    Input
    Input contains (in given order): M, N, A(1), A(2), …, A(M), u(1), u(2), …, u(N). All numbers are divided by spaces and (or) carriage return characters.
    Output
    Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
    Sample Input
    7 4
    3 1 -4 2 8 -1000 2
    1 2 6 6
    Sample Output
    3
    3
    1
    2
    Source
    Northeastern Europe 1996

题目大意:
黑盒,每次可以ADD一个数,黑盒中数列有序,有一个GET操作,可以查找第k大元素,k从0递增(在每次GET操作后递增)

题目分析:
Treap的结构中维护一个size 即可实现查询第K大 注意查询的时候是查询当前子树内的第K大,然后注意递归的时候有减法

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<ctime>
#define Maxn 30005
using namespace std;

int num[Maxn];
struct Node {
	int rank,size,val;
	Node *ch[2];
	Node (int val) :val(val) {
		rank = rand();
		ch[0] = ch[1] = NULL;
		size = 1;
	}
	void Update() {
		size = 1;
		if(ch[1] != NULL) size += ch[1] -> size;
		if(ch[0] != NULL) size += ch[0] -> size;
	}
}*root = NULL;

inline void Rotate(Node *&cur,int d) {// 1 表示右旋 
	Node *k = cur -> ch[d^1];
	cur -> ch[d^1] = k -> ch[d];
	// 注意更新 
	k -> ch[d] = cur;
	cur -> Update();
	
	cur = k;
	cur -> Update();
}

void Insert(Node *&cur,int val) {
	if(cur == NULL) cur = new Node(val);
	else {
		int d = val < cur -> val ? 0 : 1;
		Insert(cur -> ch[d],val);
		if(cur -> ch[d] -> rank > cur -> rank) Rotate(cur,d^1);
	}
	cur -> Update();
}

int K_th(Node *cur,int k) {
	if(k == 1 && cur -> ch[0] == NULL) {
		return cur -> val;
	}
	if(cur -> ch[0] == NULL) return K_th(cur -> ch[1],k - 1);// k >= 2 好像是句废话 
	if(cur -> ch[0] -> size == k - 1) return cur -> val;
	
	if(cur -> ch[0] -> size < k - 1) return K_th(cur -> ch[1],k - cur -> ch[0] -> size - 1);//左子树不够来右子树寻找 
	else if(cur -> ch[0] -> size > k - 1) return K_th(cur -> ch[0],k);
}

int main(int argc,char* argv[])  {
	int n,m,x,j = 1;
	scanf("%d %d",&n,&m);
	for(int i=1; i<=n; i++) scanf("%d",&num[i]);
	for(int i=1; i<=m; i++) {
		scanf("%d",&x);
		for(; j<=x; j++) Insert(root,num[j]);
		printf("%d\n",K_th(root,i));
	}
	
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值