POJ 3723 Conscription

37 篇文章 0 订阅
Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12905 Accepted: 4525

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

POJ Monthly Contest – 2009.04.05, windy7926778

/*很傻很天真 我刚开始居然以为是二分图匹配
匈牙利不行 又换网络流 搞了好长时间 
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define maxm 50010
#define maxn 20010
struct Edge{ int u,v,w; }e[maxm];
bool cmp(Edge a,Edge b){return a.w>b.w;}
int T,ans,n,m,fa[maxn],R;
int find(int x){
	if(fa[x]==-1)return x;
	else return fa[x]=find(fa[x]);
}

void Kursual(){
	sort(e,e+R,cmp);ans=0;
	for(int i=0;i<R;i++){
		int u=e[i].u,v=e[i].v;
		int rx=find(u),ry=find(n+v);
		if(rx==ry)continue;
		if(rx!=ry){
			ans+=e[i].w;
			fa[rx]=ry;
		}
	}
}
int main(){
	scanf("%d",&T);
	while(T--){
		scanf("%d%d%d",&n,&m,&R);
		memset(e,0,sizeof(e));
		memset(fa,-1,sizeof(fa));
		for(int i=0;i<R;i++)
			scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
			
		Kursual();
		printf("%d\n",(n+m)*10000-ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值