POJ 3281 Dining USACO07OPEN

77 篇文章 0 订阅
37 篇文章 0 订阅

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17557 Accepted: 7822

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers: N, F, and D
Lines 2…N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint
One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Source
USACO 2007 Open Gold

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
#define maxm 500000
#define maxn 100000
int S,T,F,D,N;
int head[maxn],dep[maxn],tot=1;
struct Edge{
	int to,value,next;
}e[maxm];
void Add_Edge(int u,int v,int w){
	e[++tot].to=v;e[tot].value=w;
	e[tot].next=head[u];head[u]=tot;
}
queue<int> q;
bool BFS(){
	memset(dep,-1,sizeof dep );
	dep[S]=0;q.push(S);
	while(!q.empty()){
		int u=q.front();q.pop();
		for(int i=head[u];i;i=e[i].next){
			int v=e[i].to;
			if(dep[v]==-1&&e[i].value){
				dep[v]=dep[u]+1;
				q.push(v);
			}
		}
	}
	if(dep[T]!=-1) return true;
	else return false;
}
int DFS(int u,int flow){
	int ret=0;
	if(u==T) return flow;
	for(int i=head[u];i;i=e[i].next){
		int v=e[i].to;
		if(dep[v]==dep[u]+1&&e[i].value){
			int x=DFS(v,min(e[i].value,flow));
			ret+=x;flow-=x;
			e[i].value-=x;e[i^1].value+=x;
		}
	}
	return ret;
}
void Dinic(){
	int ans=0;
	while(BFS()) ans+=DFS(S,1e9);
	printf("%d\n",ans);
	return;
}
int main(){
	scanf("%d%d%d",&N,&F,&D);
	T=N+N+F+D+20;S=0;int x;
	for(int i=1;i<=F;i++) Add_Edge(S,i,1),Add_Edge(i,S,0);
	
	for(int i=1,sumf,sumd;i<=N;i++){
		scanf("%d%d",&sumf,&sumd);
		for(int j=1;j<=sumf;j++){
			scanf("%d",&x);//
			Add_Edge(x,i+F,1);
			Add_Edge(i+F,x,0);
		}
		for(int x,j=1;j<=sumd;j++){
			scanf("%d",&x);
			Add_Edge(i+F+N,N+N+F+x,1);
			Add_Edge(N+N+F+x,i+F+N,0);
		}
	}
	for(int i=1;i<=N;i++) Add_Edge(i+F,i+F+N,1),Add_Edge(i+F+N,i+F,0);
	for(int i=1;i<=D;i++) Add_Edge(i+F+N+N,T,1),Add_Edge(T,i+F+N+N,0);
	Dinic();
	return 0;
}

源点连边向食物,食物连边向牛,牛连边向饮料,饮料连边向汇点,跑Dinic,注意中间牛拆一下点不然可能会一头牛分配多个食物

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值