POJ3613 Cow Relays

75 篇文章 0 订阅
37 篇文章 0 订阅

Cow Relays

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7665 Accepted: 3008
Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

  • Line 1: Four space-separated integers: N, T, S, and E
  • Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

  • Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9
Sample Output

10
Source

USACO 2007 November Gold

/*求从S到T恰好经过K条边的最短路径的数目
01邻接矩阵A的K次方C=A^K,C[i][j]表示i点到j点正好
经过K条边的路径数
对应于这道题,对邻接图进行K次floyd之后,
C[i][j]就是点i到j正好经过K条边的最短路
但是K次floyd难免复杂度太高了.
所以可以使用快速幂的方法,二分的往上求解
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#define maxn 1005
#define maxm 500005
#define INF 1000000000
using namespace std;
int k,n,m,S,T;
int map[maxn][maxn],tmp[maxn][maxn],dis[maxn][maxn];
int num,ans[maxn][maxn],v[maxn],exist[maxn];
void Floyd(int c[][maxn],int a[][maxn],int b[][maxn]){
    for(int k=0;k<num;k++)
        for(int i=0;i<num;i++)
            for(int j=0;j<num;j++)
                if(c[v[i]][v[j]]>a[v[i]][v[k]]+b[v[k]][v[j]])
                    c[v[i]][v[j]]=a[v[i]][v[k]]+b[v[k]][v[j]];
}
void copy(int a[][maxn],int b[][maxn]){
    for(int i=0;i<num;i++)
        for(int j=0;j<num;j++){
            a[v[i]][v[j]]=b[v[i]][v[j]];
            b[v[i]][v[j]]=INF;
        }
}
void Solve(int k){
    while(k){
        if(k&1){
            Floyd(dis,ans,map);
            copy(ans,dis);
        }
        Floyd(tmp,map,map);
        copy(map,tmp);
        k >>= 1;
    }
}
int main(){
    scanf("%d%d%d%d",&k,&m,&S,&T);
    for(int i=0;i<=1000;i++){
        for(int j=0;j<=1000;j++){
            map[i][j]=INF;
            dis[i][j]=INF;
            ans[i][j]=INF;
            tmp[i][j]=INF;
        }
        ans[i][i]=0;
    }
    num=0; int y,x,w;
    for(int i=0;i<m;i++){
        scanf("%d%d%d",&w,&x,&y);
        if(!exist[x]) exist[x]=1,v[num++]=x;
        if(!exist[y]) exist[y]=1,v[num++]=y;
        if(map[x][y]>w) map[x][y]=map[y][x]=w;
    }
    Solve(k);
    printf("%d\n",ans[S][T]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值