定义基类Point和派生类Circle,求圆的周长.

定义基类Point(点)和派生类Circle(圆),求圆的周长。Point类有两个私有的数据成员float x,y;Circle类新增一个私有的数据成员半径float r和一个公有的求周长的函数getCircumference();主函数已经给出,请编写Point和Circle类。

#include <iostream>
#include<iomanip>
using namespace std;
//请编写你的代码
int main()
{
    float x,y,r;
    cin>>x>>y>>r;
    Circle c(x,y,r);
    cout<<fixed<<setprecision(2)<<c.getCircumference()<<endl;
    return 0;
}

输入格式: 输入圆心和半径,x y r中间用空格分隔。

输出格式: 输出圆的周长,小数点后保留2位有效数字。

输入样例: 1 2 3
输出样例: 在这里给出相应的输出。例如:

Point constructor called
Circle constructor called
18.84
Circle destructor called
Point destructor called

我的代码:

#include <iostream>
#include <iomanip>
#define PI 3.14
using namespace std;
class Point{
protected:
    float X,Y;
public:
    Point(){}
    Point(float x,float y):X(x),Y(y){
        cout<<"Point constructor called"<<endl;
    }
    ~Point(){
        cout<<"Point destructor called"<<endl;
    }
};
class Circle:public Point{
    float R;
public:
    float s;
    Circle(float x,float y,float r):Point(x,y),R(r){
        cout<<"Circle constructor called"<<endl;
    };
    ~Circle(){
        cout<<"Circle destructor called"<<endl;
    }
    float getCircumference();
};
float Circle::getCircumference(){
    s=PI*R*2;
    return s;
}
int main()
{
    float x,y,r;
    cin>>x>>y>>r;
    Circle c(x,y,r);
    cout<<fixed<<setprecision(2)<<c.getCircumference()<<endl;
    return 0;
}
  • 3
    点赞
  • 17
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值