nyoj 1007 GCD(数学题 欧拉函数的应用)

                                GCD

描述
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M,please answer sum of X satisfies 1<=X<=N and (X,N)>=M.
输入
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (1<=N<=10^9, 1<=M<=10^9), representing a test case.
输出
Output the answer mod 1000000007
样例输入
3
1 1
10 2
10000 72
样例输出
1
35
1305000

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

typedef long long ll;
const int maxn=1001;
const int INF=0x3f3f3f3f;

const int mod=1000000007;

ll Euler(ll n)//欧拉函数 求φ(n)
{
    ll c=n,i;
    for(i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            while(n%i==0) n/=i;
            c=c/i*(i-1);//φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn);
        }
    }
    if(n!=1)
        c=c/n*(n-1);
    return c;
}
//计算满足条件 gcd(x,n)>=m的所有 x 的和
ll Euler_sum(ll k)
{
    if(k==1||k==2)
        return 1;
    else return k*Euler(k)/2;
}

int main()
{
    int cnt;
    ll t,n,m;
    scanf("%lld",&t);
    while(t--)
    {
        ll i,sum=0;
        scanf("%lld %lld",&n,&m);
        for(i=1; i<=sqrt(n); i++)
        {
            if(n%i==0)
            {
                if(i>=m)//计算满足条件 >=m 的 i( i 一定是n的因子)
                {
                    sum=(sum+i*Euler_sum(n/i))%mod;
                }
                //为了防止一种特殊情况才有 i*i!=n, 比如 16 4 这一组,如果没有判断条件就会在i=4的时候计算两次
                if(i*i!=n&&n/i>=m)//计算满足条件 >=m 的 n/i ( n/i 也一定是n的因子)
                {
                    //按步骤走这里有两种情况:(1)i和n/i都满足>=m的条件(2)i不满足>=m但是n/i满足
                    //不管哪种情况如果n/i满足>=m就往下走
                    sum=(sum+n/i*Euler_sum(i))%mod;
                }
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值