Clumsy Keke

Clumsy Keke

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


 

Problem Description

Keke is currently studying engineering drawing courses, and the teacher has taught her how to find its volume through the three views of the part. But her brain doesn't work well that she can't find the volume of complex parts. So she needs your help.

To simplify the problem, the part is made up of cubes with side length 1, and the vertices of these cubes are all on the grid. Give you three 0/1 matrices, each representing each of the three views. 0 means that there is no projection of cubes at this position of the view; 1 means that there is a projection of cubes at this position of the view.

Now Keke wants you to help her find the volume of the part determined by the three views.

 

 

Input

There are mutiple test cases, the number of which is no more than 10. For each test case:

The first line of input contains three integers mx,my,mz(1≤mx,my,mz≤99) , which represent the coordinate range of all possible cubes (i.e. all possible cubes are in the cuboid area whose body diagonal is from (1,1,1) to (mx,my,mz)).

Following input a 0/1 matrix with mx lines and my columns representing the front view, and the y-th column of the x-th row represents the projection of all the cubes in the front view such as (x,y,?).

Following input a 0/1 matrix with my lines and mz columns representing the side view, and the z-th column of the y-th row represents the projections of all the cubes in the side view such as (?,y,z).

Following input a 0/1 matrix with mz lines and mx columns representing the top view, and the x-th column of the z-th row represents the projection of all the cubes of the top view such as (x,?,z).

The '?' in the above coordinates represents any integer. Numbers in the same line are separated by spaces. For more detailed input information, please see the sample.

 

 

Output

For each test case:

The first line of output should contain an integer, representing the volume of the part determined by the three views. If the determined part is not unique, find the largest of all possible parts.

Keke's teacher promises that there is at least one part that satisfies the input.

 

 

Sample Input

5 6 4
1 1 1 1 1 1
0 0 0 1 0 1
0 0 0 1 0 1
0 0 0 0 0 1
0 0 0 0 0 1
0 1 1 0
1 0 0 1
0 0 0 1
0 0 0 1
0 0 0 1
1 1 1 1
1 0 0 0 0
1 0 0 0 0
1 0 0 0 0
1 1 1 1 1

 

Sample Output

 

17

Hint

 [分析]  这道题比较新颖,我觉得也是一道思维题目,我们通过分析,可以把问题进行转化,先建立一个三维数组进行保存输入时的值,但是需要注意的是加入输入的是(x,y,?)  我们需要把相应的 z 层都进行加法运算,这样三视图就被一个三维数组保存了,最后三重 for 循环判断三维数组的值是否等于3 ,若等于则结果加一,最终输出结果就可以了。

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int s[110][110][110];
int main()
{
    int a,b,c,n,ans=0;
    while(cin>>a>>b>>c)
    {
        ans=0;
        memset(s,0,sizeof(s));
        for(int i=1;i<=a;i++)
        {
            for(int j=1;j<=b;j++)
            {
                cin>>n;
                for(int k=1;k<=c;k++)
                    s[i][j][k]=n;
            }
        }
        for(int i=1;i<=b;i++)
        {
            for(int j=1;j<=c;j++)
            {
                cin>>n;
                for(int k=1;k<=a;k++)
                    s[k][i][j]+=n;
            }
        }
        for(int i=1;i<=c;i++)
        {
            for(int j=1;j<=a;j++)
            {
                cin>>n;
                for(int k=1;k<=b;k++)
                    s[j][k][i]+=n;
            }
        }
        for(int i=1;i<=a;i++)
        {
            for(int j=1;j<=b;j++)
            {
                for(int k=1;k<=c;k++)
                {
                    if(s[i][j][k]==3)
                        ans++;
                //cout<<s[i][j][k]<<" ";
                }
            }
              //  cout<<endl;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值