【PAT】1129 Recommendation System (25 分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题意:给出N(用户点击次数),K(每次最多推荐个数),接下来一行给出N个数字,即用户每次点击的item的编号 (item编号范围[1,N])。对每一次点击,给用户推荐它之前点击过的item(要注意推荐是根据每次点击前的数据,所以每次读入item的值之后,先输出推荐再更新set),最多K个,第一次点击没有推荐。推荐的item按点击频率降序排列,相同频率的按item编号升序排列。

第一次用的方法如下,两个测试点超时:

//TLE - 2 test points unaccepted
#include <iostream>  
#include <algorithm>
#include <vector>
#include <unordered_map>
using namespace std;
int freq[50002];
bool Comp(int a, int b) {
	return (freq[a] != freq[b] ? freq[a] > freq[b] : a < b);
}
int main() {
	int n,k,item;
	vector<int> ans;
	unordered_map<int, bool> exist;
	scanf("%d%d",&n,&k );
	scanf("%d",&item );
	freq[item]++;
	exist[item] = true;
	ans.push_back(item);
	for(int i = 2; i <= n; i++) {
		scanf("%d",&item );
		printf("%d:",item);
		sort(ans.begin(),ans.end(),Comp ); 
		for(int j = 0; j < ans.size() && j < k; j++) {
			printf(" %d",ans[j]);
		}
		printf("\n");
		freq[item]++;
		if(exist[item] != true) {
			exist[item] = true;
			ans.push_back(item);
		}
	}
	return 0;
}

第二次改成使用set存储包含item编号(val)及其被点击频率(fre)的结构体,并在结构体内重载 " < ",利用set自动排序的特点,使得set内的存储顺序即为所求顺序。

#include <iostream>  
#include <set>
using namespace std;
int freq[50002];
struct node{
	int val, fre;
	//node(int a, int b) {val = a; fre = b;}
	bool operator < (const node &a) const {
		return (fre != a.fre ? fre > a.fre : val < a.val);
	}
};
int main() {
	int n,k,item;
	set<node> ans;
	scanf("%d%d",&n,&k );
	for(int i = 0; i < n; i++) {
		scanf("%d",&item );
		if(i != 0) {
			printf("%d:",item);
			int cnt = 0;
			for(auto it = ans.begin(); it != ans.end() && cnt < k; it++) {
				printf(" %d",it->val);
				cnt++;
			}
			printf("\n");
		}
		auto it = ans.find(node{item, freq[item]});
		if( it != ans.end() ) ans.erase(it);
		freq[item]++;
		ans.insert(node{item, freq[item]});
	}
	return 0;
}

也可以在结构体内添加构造函数,如下:

#include <iostream>  
#include <set>
using namespace std;
int freq[50002];
struct node{
	int val, fre;
	node(int a, int b) {val = a; fre = b;}  //changed
	bool operator < (const node &a) const {
		return (fre != a.fre ? fre > a.fre : val < a.val);
	}
};
int main() {
	int n,k,item;
	set<node> ans;
	scanf("%d%d",&n,&k );
	for(int i = 0; i < n; i++) {
		scanf("%d",&item );
		if(i != 0) {
			printf("%d:",item);
			int cnt = 0;
			for(auto it = ans.begin(); it != ans.end() && cnt < k; it++) {
				printf(" %d",it->val);
				cnt++;
			}
			printf("\n");
		}
		auto it = ans.find( node(item, freq[item]) );  //changed
		if( it != ans.end() ) ans.erase(it);
		freq[item]++;
		ans.insert( node(item, freq[item]) );  //changed
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值