PAT - 甲级 - 1129. Recommendation System (25)(STL - set)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目大意:

题目要求完成一个简单的推荐系统的功能,这个功能是根据用时已经查看过的数字来推荐用户查看哪些数字。在看第一个数字的时候不推荐任何数字,因为再次之前没有看过任何数字。第一行给出的n和k分别表示查看数字的总次数,和推荐数字的最多个数(一次最多推荐k个)。推荐的数字按照用户之前看过的数字的个数来推荐,次数大的优先输出,如果次数一样,那么数字小的优先输出。


题目思路:

看到根据次数的大小输出,首先想到用map来记录大小,涉及到排序先到用vector来存储排序。map的key和value在排序中都会涉及到,数据处理会很麻烦,那么把map改为用结构体存储是否可以呢?用结构体的话如果将数字(num)和出现次数(cnt)都设置为成员变量的话,那么cnt的更新就是一个新的问题。如果将num设置为结构体数组下标,cnt的更新解决了,但是排序有成了问题。我们可以使用set,将重定义运算符后的结构体添加到set中,让 他自动排序,跟新cnt可以先移除(未更新的)后添加(更新后的)。


题目代码:

#include <cstdio>
#include <cstring>
#include <set>
using namespace std;

struct node{
	int num, cnt;
	node(int num, int cnt):num(num),cnt(cnt){}
	bool operator < (const node &a)const{ // 重载运算符 
		return cnt != a.cnt ? cnt > a.cnt : num < a.num;
	}
};
set<node> s;
int times[50001], n, k;
int main(){
	scanf("%d%d",&n,&k);
	memset(times, 0, sizeof(times));
	int num;
	for(int i = 0; i < n; i++){
		scanf("%d",&num);
		if(i){
			printf("%d:",num);
			int cnts = 0; // 记录输出的次数 
			for(auto it = s.begin(); cnts < k && it != s.end(); it++){
				printf(" %d",it->num);
				cnts++;
			}
			puts("");
		}		
		auto it = s.find(node(num,times[num])); // 判断set中是否存在 
		if(it != s.end()) s.erase(it); 
		times[num]++; // 跟新浏览次数 
		s.insert(node(num,times[num]));
	}
	return 0;
}


  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值