POJ 3984 迷宫问题<记忆BFS>

the reason of failure:1、一遍过

important points:1、迷宫题如何记录该格子的上一个是哪个?

可以通过定义一个A[d.x][d.y].x=c.x,可以通过定义一个A[d.x][d.y].y=c.y.c是从哪个格子,d为所到的格子.

然后再用一个数组储存,逆序输出便为路径.

thinking:bfs

E - A strange lift
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist. 
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

Input

The input consists of several test cases.,Each test case contains two lines. 
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3
代码:

#include <iostream>
#include <queue>
#include <string.h>
using namespace std;

int dr[]={0,1,0,-1};
int dc[]={1,0,-1,0};
struct ttt{
	int x,y;
};
struct ccc{
	int x,y;
}TT[10][10];
int main(){
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	queue<ttt>qq;
	int a[6][6];
	int i,j,k,l;
	bool walked[6][6];
	memset(walked,0,sizeof(walked));
	for(i=0;i<5;i++)
		for(j=0;j<5;j++)
			cin >> a[i][j];
	ttt c,d;
	c.x=0;
	c.y=0;
	qq.push(c);
	walked[0][0]=1;
	while(!qq.empty()){
		c=qq.front();
	//		cout << c.x << c.y <<endl;
		qq.pop();
		if(c.x==4&&c.y==4)break;
	for(i=0;i<4;i++){
	d.x=dr[i]+c.x;
	d.y=dc[i]+c.y;
	if(a[d.x][d.y]==0&&walked[d.x][d.y]==0&&d.x>=0&&d.y>=0&&d.x<5&&d.y<5){
		walked[d.x][d.y]=1;
		qq.push(d);
		TT[d.x][d.y].x=c.x;
		TT[d.x][d.y].y=c.y;
	}
	}
}	
	i=-1;
	ttt gg[10];
	while(TT[c.x][c.y].x!=0||TT[c.x][c.y].y!=0){
		gg[++i].x=TT[c.x][c.y].x;
		gg[i].y=TT[c.x][c.y].y;
		d.x=TT[c.x][c.y].x;
		d.y=TT[c.x][c.y].y;
		c.x=d.x;
		c.y=d.y;
	}
	cout << "(0, 0)" << endl;
	for(j=i;j>=0;j--)
		cout << "(" << gg[j].x << ", " << gg[j].y << ")" << endl;
	cout << "(4, 4)" << endl;
	return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值