最小点覆盖问题 二分图

Machine Schedule

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.   

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 
Output
The output should be one integer per line, which means the minimal times of restarting machine.  

Sample Input
   
   
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 
Sample Output
   
   
3

题解:
有两台机器A和B以及k个需要运行的任务。每台机器有n,m种不同的模式,而每个任务都恰好能在一台机器上运行。 
机器A上有模式 0, 1, …, n-1,机器B上有模式: 0, 1, … , m-1。 
开始的工作模式都是mode_0。每个任务有对应的运行模式,(i, x, y)表示i任务对应的A B机器上的运行模式x, y。 
每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重启一次。 
请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。并求其值。 
每个任务要有对应A B机器的模式中至少要有一种来运行,问题转化为,求二分图中最少的点(模式)使得每个边(模式对应的任务)至少和其中的一个点覆盖。 
也就是二分图最小顶点覆盖问题

最小点覆盖数=最大匹配数
#include<stdio.h>
#include<string.h>

int n,m,k,ans=0;
int map[105][105];
int link[105];
int visit[105]; 

int dfs(int i){
	int j;
	for(j=0;j<m;j++){
		if(map[i][j] && !visit[j]){
			visit[j]=1;
			if(!link[j] || dfs(link[j]) ){
				link[j]=i;
				return 1;
			}
		}
	}
	return 0;
} 

int main(){
	int a,x,y,i;
	memset(map,0,sizeof(map));
	memset(link,0,sizeof(link));
	scanf("%d%d%d",&n,&m,&k);
	for(i=0;i<k;i++){
		scanf("%d%d%d",&a,&x,&y);
		map[x][y]=1;
	}
	for(i=0;i<n;i++){//从每个顶点出发,依次遍历 
		memset(visit,0,sizeof(visit));
		if(dfs(i)==1){//看是否能找到新的一对  
			ans++;
		}
	}
	printf("%d",ans);
	
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值