小白學JAVA-----P1001

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
  
  
1 100
 

Sample Output
  
  
1 5050
 

Author
DOOM III
------------------------------------------------


import java.util.Scanner;


class Main{

public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int sum=0;
int a=sc.nextInt();
for(int i=1;i<=a;i++){
sum=sum+i;
}
System.out.println(sum);
System.out.println();
}
}
}
很简单的一道水题,意思就是 输入一个数,求这个数的前n项和,例如输入100就是1+2+3+··100;唯一需要注意的是每输出一个案例需要额外换一次行,这就是ACM,不容许一点错误
注意的是
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值