POJ1163

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48800 Accepted: 29478

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

    拿到这个题目,本能的反应——动态规划。思路也很清晰例如以下的这个三角阵
                                   7

                              3         8

                         8         1         0

                   2         7          4         4

              4        5         2          6         5

    边界由于怎么走都只有一种选择,所以不用考虑两条边界。然后继续往下看,我的方法类似于打表,逐层逐个元素计算,懒得打出来了,直接上我的公式b[i][j]=a[i][j]+max(b[i-1][j-1],b[i-1][j])。然后在最后一行找出最大值输出即可(别用排序写=。=)。以下是我的代码

#include <stdio.h>
#define M 105

int a[M][M],b[M][M];
int max(int m,int n)
{
    return m>n?m:n;
}
int main()
{
    int n;
    //freopen("in.txt","r",stdin);
    scanf("%d",&n);
    for(int i=0; i<n; i++)
        for(int j=0; j<=i; j++)
            scanf("%d",&a[i][j]);
    b[0][0]=a[0][0];
    for(int i=1; i<n; i++)
    {
        b[i][i]=b[i-1][i-1]+a[i][i];
        b[i][0]=b[i-1][0]+a[i][0];
    }
    for(int i=2; i<n; i++)
        for(int j=0; j<i; j++)
            b[i][j]=a[i][j]+max(b[i-1][j-1],b[i-1][j]);
    int sum=b[n-1][0];
    for(int i=1; i<n; i++)
        sum=max(b[n-1][i],sum);
    printf("%d\n",sum);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值