PAT甲级1001

题目:

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).


Input


Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.


Output


For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.


Sample Input
-1000000 9
Sample Output

-999,991

代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main(){
     int a,b;
    cin >> a >> b;
     int sum = a+b;
     if(sum < 0){
        cout << "-";
        sum = -sum;
    }
     if(sum >= 1000000)
         printf( "%d,%03d,%03d \n ",sum/ 1000000,(sum% 1000000)/ 1000,sum% 1000);
     else if(sum >= 1000)
         printf( "%d,%03d \n ",sum/ 1000,sum% 1000);
     else
        cout << sum;
     return 0;
}

小结:

渣渣楼主弄了一晚上终于搞定,踩了一个大坑,忘记了在打印的时候需要格式输出避免出现1000000 + 1000000 = 2,0,0的尴尬情况。另外其实第一次做的时候用的是vector容器,不过网上查了一下还是这个方法最简单。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值