PAT甲级1003

1003. Emergency (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.


Input


Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.


Output


For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.


Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output

2 4

以上是题目,解体思路是通过迪杰斯特拉最短路径算法在查找最短路径的同时通过一个变量对路径数量进行计数,一个变量对点权值进行累加。

代码如下

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX = 500;

int main(){
     int vec[MAX][MAX]; //用于保存路径距离
     int dist[MAX]; //用于保存第i条路到起点的最短路径
     int city_cont= 0,road_cont= 0; //分别记录城市数量,道路数量
     int a= 0,b= 0; //在输入路径距离时标记两个城市
     int weight[MAX]={ 0}; //权值,记录每个城市救援队数量
     int sum_weight[MAX] = { 0}; //权值和,记录到达i城市时所遇到的最大救援队数量
     int number[MAX]={ 0}; //记录到达i城市的最小路径数量
     int bg = 0,ed = 0; //初始城市 目标城市
     bool value[MAX] = { false}; //记录以及该城市的最短路径是否已经查找到
    
memset(vec,- 1, sizeof(vec));
     memset(dist,- 1, sizeof(dist));
    cin >> city_cont >> road_cont >> bg >> ed;
     getchar();
for( int i = 0; i < city_cont; ++i)
        cin >> weight[i];
     getchar();
     for( int i = 0 ; i< road_cont; ++i){
        cin >> a >> b;
        cin >> vec[a][b];
        vec[b][a] = vec[a][b];
         getchar();
    }
    dist[bg] = 0;
    sum_weight[bg] = weight[bg];
    number[bg] = 1;
     for( int j = 0 ; j < city_cont; ++j){
         int min = - 1;
         int k ;
         for( int i = 0; i < city_cont; ++i){
         if(value[i] != true && dist[i] != - 1 && (min == - 1 || dist[i] < min)){
             min = dist[i];
             k = i;
         }
        }
        value[k] = true;
         if(k == ed) //如果已经搜到了目标城市的最短路径,结束循坏。
             break;
for( int i = 0; i < city_cont; ++i){
             if(value[i] == false && vec[k][i] != - 1){
                 if(dist[i] == - 1 || dist[k] + vec[k][i] < dist[i]){
                    dist[i] = dist[k] + vec[k][i];
                    number[i] = number[k];
                    sum_weight[i] = sum_weight[k] + weight[i];
                }
                 else if(dist[k] + vec[k][i] == dist[i]){
                    number[i] = number[k]+number[i];
                     if(sum_weight[k] + weight[i] > sum_weight[i])
                        sum_weight[i] = sum_weight[k] + weight[i];
                }
            }
        }
    }
    cout << number[ed] << " " << sum_weight[ed] << endl;
     return 0;
}


小结:好像可以通过DFS来实现,没试过,有机会可以试试。然后我又踩了一个坑,怪自己以前C/C++没学好,数组初始化比如a[1001] = {0} 全部置零没问题,但是!!a[1003] = {-1} 就出问题了!!只有a[0]被赋值了-1,其余值都为0!!!,查错查了一天多才发现!!心塞,用了memset解决。最后,迪杰斯特拉算法参考了一篇大佬的博客:https://www.liuchuo.net/archives/2357

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值