PAT甲级1004

1004. Counting Leaves (30)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input


Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:


ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output


For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.


The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.


Sample Input
2 1
01 1 02
Sample Output

0 1

以上是题目

以下是代码,用了一个dfs遍历整个数找叶子节点

#include <iostream>
#include <vector>
#include <cstdio>

using namespace std;

int depth_max = 0;

void dfs( int i , int depth ,vector< int>*a, int*b ){
     if(a[i]. size()== 0){
b[depth]++;
         if(depth > depth_max)
            depth_max = depth;
         return;
    }
     for(vector< int>::iterator j = a[i]. begin();j!=a[i]. end();j++)
         dfs(*j,depth+ 1,a,b);
}

int main(){
     int N,M;
     int id,k,id_son;
    vector< int>a[ 100];
     int b[ 100]={ 0};
cin >> N >> M;
     getchar();
     for( int i= 0;i<M;i++){
        cin >> id >> k;
         for( int j= 0;j<k;j++){
cin >> id_son;
a[id]. push_back(id_son);
        }
    }
     dfs( 1, 0,a,b);
    cout << b[ 0];
     for( int i= 1;i<=depth_max;i++)
        cout<< " "<<b[i];
    cout<<endl;
     return 0;
}

小结:dfs算法看起来不难,但是我真正用起来还是觉得很有难度,主要不怎么打代码吧。。。。遇到一个小坑,数组一定要进行初始化,默认不是0!!另外,个人题目理解水平好渣啊啊,花了好久才弄懂题目的意思。。。。。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值