PAT甲级1009

1009. Product of Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.


Input Specification:


Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.


Output Specification:


For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.


Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 3 3.6 2 6.0 1 1.6

以上是题目

以下是代码

 

#include<iostream>
#include<map>
#include<stdio.h>

using namespace std;
map<int,float> poly;
map<int,float> poly_2;
int main(){
  int count1 = 0, count2 = 0;
  int n = 0,tmp_n = 0;
  float m = 0.0,tmp_m = 0.0;
  cin >> count1;
  for(int i = 0; i < count1; i++){
    cin >> n >> m;
    poly[n] = m;
  }
  cin >> count2;
  for(int i = 0; i< count2; i++){
    cin >> n >> m;
    for(map<int,float>::iterator p = poly.begin(); p != poly.end(); p++){
      tmp_n = n + p->first;
      tmp_m = m * p->second;
      poly_2[tmp_n] += tmp_m;
    }
  }
  for(map<int,float>::iterator p = poly_2.begin(); p != poly_2.end();){
    if(p -> second == 0)
      p = poly_2.erase(p);
    else
      p++;
   }
  cout << poly_2.size();
  for(map<int,float>::reverse_iterator p = poly_2.rbegin(); p != poly_2.rend(); p++){
    printf(" %d %.1f",p->first,p->second);
  }
  return 0;
}

小结:基本模拟题,用两个map容器,一个用来存储第一行的数据,另一个存储运算结果,注意的是,运算结果中可能存在系数为0的项需要舍去。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值