1021. Couples

题目:

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more.

Can we remove all the couples out of the circle?

 

Input

 

There may be several test cases in the input file. In each case, the first line is an integer N(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.
N = 0 indicates the end of the input.

 

Output

 

Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

 

Sample Input

4
1 4
2 3
5 6
7 8

2
1 3
2 4

0

Sample Output

Yes
No

分析:

贪心就可以了:遇到一个站在相邻位置的夫妇直接将他们消除

可以看作是括号匹配,用栈实现

答案:

#include<iostream>
#include<stack>
using namespace std;
bool couple(int cp[],int n){
    stack<int> stk;
    for(int i = 1;i<=2*n;i++){
        if(!stk.empty() && stk.top() == cp[i])
            stk.pop();
        else
            stk.push(cp[i]);
    }
    return stk.empty();
}

int main(){
    int n;
    while(cin >> n && n!=0){
        int cp[2*n+1];
        int a,b;
        for(int i = 1;i<=n;i++){
            cin >> a >> b;
            cp[a] = cp[b] = i;//1~n组
        }
    if(couple(cp,n))
        cout << "Yes"<<endl;
    else
        cout << "No"<<endl;

    }


return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值