1021. Deepest Root (25) DFS

12 篇文章 0 订阅

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
题意:给定n个点,n-1条边, 问你能否构成一棵树,如果能,那么输出能构成深度最深的的树,把他们的根输出出来, 如果不能构成,输出它由几个部分构成

题解:可以先用dfs求出他是否是一部分构成的(也可以用并查集求),然后枚举每一个点,以他们为根构成的树的深度是多少,记录最大值,最后输出一边就好了.


#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;
const int N = 10010;
vector<int> V[N];
bool vis[N];

void dfs(int pre, int u) {
    vis[u] = true;
    for (int i = 0; i < V[u].size(); ++i) 
        if (V[u][i] != pre && vis[V[u][i]] == false)
            dfs(u, V[u][i]);
}

int find_deep(int pre, int u) {
    int deep = 0;
    for (int i = 0; i < V[u].size(); ++i) 
        if (V[u][i] != pre) {
            int tmp = find_deep(u, V[u][i]);
            if (deep < tmp) deep = tmp;
        }
    return deep + 1;
}

int main() {
    int n, u, v;
    scanf("%d", &n);

    for (int i = 1; i < n; ++i) {
        scanf("%d%d", &u, &v);
        V[u].push_back(v);
        V[v].push_back(u);
    }

    int cnt = 0;

    memset(vis, false, sizeof(vis));
    for (int i = 1; i <= n; ++i) {
        if (vis[i] == false) {
            ++cnt;
            dfs(-1, i);
        }
    }

    if (cnt != 1) {
        printf("Error: %d components\n", cnt);
    }
    else {
        int dep[N];
        int Max = -1;

        for (int i = 1; i <= n; ++i) {
            dep[i] = find_deep(-1, i);
            if (Max < dep[i]) Max = dep[i];
        }

        for (int i = 1; i <= n; ++i)
            if (dep[i] == Max)
                printf("%d\n", i);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值