走迷宫——DFS


        Input      

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

输入m,n表示迷宫大小。随后m行n列输入迷宫。

  Output

         如果可以走出去输出 Yes  否则输出 No.当m或n为0时结束输出.

 Sample Input

4 4

S.X.

..X.

..XD

....

4   4

S.X.

X...

XXXX

D...

0 0

Sample Output

     Yes

     No

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int w,h;
int x,y;
int p;
char map[8][8];
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
void dfs(int x,int y)
{
if(x<0||x>=h||y<0||y>=w)
return ;
if(map[x][y]=='X')
return ;
if(map[x][y]=='D')
{
p=1;
}
else
{
map[x][y]='X';
for(int i=0;i<4;i++)
dfs(x+fx[i],y+fy[i]);
}
}
int main()
{
scanf("%d%d",&h,&w);
while(h&&w)
{
for(int i=0;i<h;i++)
{
scanf("%s",&map[i]);
for(int j=0;j<w;j++)
{
if(map[i][j]=='S')
{
x=i;
y=j;
}
}
}
p=0;
dfs(x,y);
if(p)
printf("Yes\n");
else
printf("No\n");
scanf("%d%d",&h,&w);
}



return 0;
}





       

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值