Windows Message Queue(优先队列)

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

思路:模拟+优先队列,熟记格式,详见代码;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
	char s[100]; 
	int a,b,c;//s代表指令字符串,a代表 指令,b代表指令等级,c代表前后顺序; 
	friend bool operator<(node x,node y)//优先队列格式,类似于sort排序; 
	{
		if(x.b!=y.b)
			return x.b>y.b;
		else return x.c>y.c;
	}
}q;//也可以在主函数内:node q; 
int main()
{
	char v[100];
	int k=0;
	priority_queue<node> Q;//优先队列格式; 
	while(scanf("%s",v)!=EOF)
	{
		if(!strcmp(v,"PUT"))
		{   // 记住格式,套用;
			scanf("%s %d %d",q.s,&q.a,&q.b);
			q.c=++k;
			Q.push(q);
		}
		else
		{
			if(Q.empty())
				printf("EMPTY QUEUE!\n");
			else 
			{   //记住格式,套用; 
				q=Q.top();
				Q.pop();
				printf("%s %d\n",q.s,q.a);
			}
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值