poj 1611 The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

题意:每一个案例第一行 n,m。n个人编号 0 ~ n-1,随后 m 行,每行开头为 k,随后跟 k 个元素,0为病毒嫌疑人,该组有嫌疑人则该组全为嫌疑人,也就是找和0在一个集合的有多少人;

思路:套用模板,熟悉 find 函数和 pre 数组,一定要理解路径压缩;

这棵树未必只有两层,所以善用 find 函数,找树顶和嫌疑人相同的元素共 tot,tot 即为答案,详见代码分析;

#include<stdio.h>
int pre[30000+10],a[30000+10];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int i=x,j;
	while(i!=r)//希望能理解路径压缩;
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
int main()
{
	int m,n,i,p1,p2,k;
	while(scanf("%d %d",&m,&n) && (m+n))
	{
		int tot=0;
		for(i=1;i<=m;i++)
			pre[i]=i;
		while(n--)
		{
			scanf("%d",&k);
			for(i=1;i<=k;i++)
			{
				scanf("%d",&a[i]);
				a[i]++;
				if(i>1)
				{
					int fx=find(a[i]);
					int fy=find(a[i-1]);
					if(fx!=fy)
						pre[fx]=fy;
				}
			}
		}
		for(i=1;i<=m;i++)
		{  //利用find函数,其是用来寻找老大,因为有未压缩的元素
		   //所以,寻找树顶端元素,和find(1)相同的必定为感染者;
			if(find(i)==find(1)) 
				tot++;
		}
		printf("%d\n",tot);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值