hdu1372 Knight Moves

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output
5
28
0

思路:八个方向表示出来,其余按照模板套用,不过如果早早写下这题,2n皇后问题的剪枝早就想到了;

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int visit[1010][1010];
int t,n;
struct node
{
	int x;
	int y;
	int step;
	bool friend operator<(node a,node b)
	{
		return a.step>b.step;
	}
};
void bfs(int startx,int starty,int endx,int endy)
{
	int m1[8]={1,2,2,1,-1,-2,-2,-1};//移动的八个方向;
	int m2[8]={2,1,-1,-2,-2,-1,1,2};
	priority_queue<node> q;
	node now,next;
	now.x=startx;
	now.y=starty;
	now.step=0;
	q.push(now);
	while(!q.empty())
	{
		next=q.top();
		q.pop();
		if(next.x==endx && next.y==endy)
			break;
		for(int i=0;i<8;i++)
		{
			now.x=next.x+m1[i];
			now.y=next.y+m2[i];
			if(0<=now.x && now.x<n && 0<=now.y && now.y<n && !visit[now.x][now.y])//经典之笔;
			{
				visit[now.x][now.y]=1;
				now.step=next.step+1;
				q.push(now);
			}
		}
	}
	printf("%d\n",next.step);
}
int main()
{
	int x1,x2,y1,y2;
	scanf("%d",&t);
	while(t--)
	{
		memset(visit,0,sizeof(visit));
		scanf("%d",&n);
		scanf("%d %d",&x1,&y1);
		scanf("%d %d",&x2,&y2);
		if(x1==x2 && y1==y2)
		{
			printf("0\n");
			continue;
		}
		bfs(x1,y1,x2,y2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值