BFS - Knight Moves

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input
The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output
5
28
0

题意:给定初始位置和最终位置,要求“?”到达最终位置所用的最少步数。(注意?的行走规则)

思路:运用BFS对每个点进行广搜,并存入队列,优先到的肯定就优先出来,即符合题意最少步数。

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
int vis[301][301],n; 
int d[8][2]={{-2,-1},{-1,-2},{1,-2},{2,-1},{2,1},{1,2},{-1,2},{-2,1}}; //?的8种走法
int start1,start2,end1,end2;
struct node
{
int x;
int y;
int step;
};
queue<node>Q;
int bfs()
{
node now,next;
int i;
now.x=start1;   //bfs标准格式,先赋值给new,再压入
now.y=start2;
now.step=0;
Q.push(now);
vis[now.x][now.y]=1;
while(!Q.empty())
{
now=Q.front();   //拿出,并进行判断
Q.pop();
if(now.x==end1&&now.y==end2)   //到了终点则返回值
return now.step;
vis[now.x][now.y]=1;   //记录该点已走过
for(i=0;i<8;i++)   //生成下一节点
{
next.x=d[i][0]+now.x;    
next.y=d[i][1]+now.y;
if(next.x<0||next.y<0||next.x>=n||next.y>=n)   //越界则无效,重新生成节点
continue;
if(!vis[next.x][next.y])    //生成节点有效,没有走过
{
    next.step=now.step+1;     //到下一节点位置,步数加一
Q.push(next);     //入队
vis[next.x][next.y]=1;   //标记下一节点已走过
if(next.x==end1&&next.y==end2)   //对下一节点也进行前面类似的判断,到了终点就退出
return next.step;
}
}
}
}
int main()
{
int cas;
while(~scanf("%d",&cas))
{
while(cas--)
{
scanf("%d",&n);
scanf("%d%d",&start1,&start2);
scanf("%d%d",&end1,&end2);
memset(vis,0,sizeof(vis));    
while(!Q.empty())   //初始化Q!!(之前这里没有初始化一直出错), 另外一种则把队列放入bfs函数中定义,则不用初始化
Q.pop();
printf("%d\n",bfs());
}
}
return 0;
}

题后反思:初步接触BFS,不太理解如何进行的一步一步点的扩散过程。 (注意for循环,自己画了个队列,模拟几步就能发现其中的原理)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值