CodeForces 586A

A -A
Crawling in process... Crawling failed
Time Limit: 1000MS     Memory Limit: 262144KB     64bit IO Format: %I64d & %I64u

Description

Alena has successfully passed the entrance exams to the university and is now looking forward to start studying.

One two-hour lesson at the Russian university is traditionally called a pair, it lasts for two academic hours (an academic hour is equal to 45 minutes).

The University works in such a way that every day it holds exactly n lessons. Depending on the schedule of a particular group of students, on a given day, some pairs may actually contain classes, but some may be empty (such pairs are called breaks).

The official website of the university has already published the schedule for tomorrow for Alena's group. Thus, for each of then pairs she knows if there will be a class at that time or not.

Alena's House is far from the university, so if there are breaks, she doesn't always go home. Alena has time to go home only if the break consists of at least two free pairs in a row, otherwise she waits for the next pair at the university.

Of course, Alena does not want to be sleepy during pairs, so she will sleep as long as possible, and will only come to the first pair that is presented in her schedule. Similarly, if there are no more pairs, then Alena immediately goes home.

Alena appreciates the time spent at home, so she always goes home when it is possible, and returns to the university only at the beginning of the next pair. Help Alena determine for how many pairs she will stay at the university. Note that during some pairs Alena may be at the university waiting for the upcoming pair.

Input

The first line of the input contains a positive integer n (1 ≤ n ≤ 100) — the number of lessons at the university.

The second line contains n numbers ai (0 ≤ ai ≤ 1). Numberai equals0, if Alena doesn't have the i-th pairs, otherwise it is equal to1. Numbersa1, a2, ..., an are separated by spaces.

Output

Print a single number — the number of pairs during which Alena stays at the university.

Sample Input

Input
5
0 1 0 1 1
Output
4
Input
7
1 0 1 0 0 1 0
Output
4
Input
1
0
Output
0

Sample Output

Hint

In the first sample Alena stays at the university from the second to the fifth pair, inclusive, during the third pair she will be it the university waiting for the next pair.

In the last sample Alena doesn't have a single pair, so she spends all the time at home.

思路:开头的0不加,结束的0不加,中间连续两个0的加上;(水题,模拟一下就哈)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[110];
int main()
{
	int t,i;
	while(scanf("%d",&t)!=EOF)
	{
		int k=0;
		bool flag=true,ans=true;
		memset(a,-1,sizeof(a));
		for(i=0;i<t;i++)
			scanf("%d",&a[i]);
		for(i=0;i<t;i++)
		{
			if(a[i]==1 && flag)
			{
				k++;
				flag=false;
			}
			else if(!a[i] && !a[i+1] || !a[i-1] && !a[i] || !a[i] && i==t-1)
			{
				continue;
			}
			else if(!flag)
				k++;
		}
		printf("%d\n",k);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值