poj 3687 Labeling Balls【反向拓扑】

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14715 Accepted: 4314

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

题目大意:

t组数据。N个球,从1~N编号,质量不同,范围1~N,无重复。给出小球间的质量关系(<), 要求给每个球贴标签,标签表示每个球的质量。按编号输出每个球的标签。如果解不唯一,按编号小的质量小排。

思路:入度的对象和边建立的方向都要改变(题意相当于x<y),而且判断不出大小关系的情况下 i 值越大,球越重,反向建立拓扑关系,然后就和普通拓扑一样处理:找入读为0(也就是顶点),拆边,更新入度,out数组存储结果。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define max_n 210
typedef long long LL;
using namespace std;
int mapp[max_n][max_n];
int in[max_n],out[max_n];
int t,n,m,x,y;

void toposort()
{
	bool flag=true;
	int ans=0,i=0,k=n;
	while(k>=1)
	{
		for(i=n;i>=1;i--)
		{
			if(in[i]==0)
			{
				for(int j=1;j<=n;j++)
				{
					if(mapp[i][j]==1)
						in[j]--;
				}
				in[i]--;
				out[i]=k--;
				break;
			}
		}
		if(i==0) //在k值满足条件的情况下,找不到in==0 
		{
			flag=false;
			break;
		} 
	}
	if(!flag) printf("-1\n");
	else
	{
		for(int i=1;i<=n;i++)
		{
			if(i>1) printf(" ");
			printf("%d",out[i]);
		}
		printf("\n");
	}
}

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		memset(mapp,0,sizeof(mapp));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d %d",&n,&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d %d",&x,&y);
			if(mapp[y][x]) continue; 
			mapp[y][x]=1; //看清楚y,x 反拓扑 
			in[x]++;  
		}
		toposort();
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值