Roads in the North
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 2933 | Accepted: 1442 |
Description
Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.
The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.
The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input
Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output
You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input
5 1 6 1 4 5 6 3 9 2 6 8 6 1 7
Sample Output
22
题意:
给出多组无向边,并给出边权,以EOF结束;
思路:
树的直径裸题,主要还是找任意一点深搜出树直径的一个端点s(网上有证明),再从s出发找另一个端点t,则 s —> t 就是树的直径;
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define max_n 100000
using namespace std;
int head[max_n],dis[max_n],vis[max_n];
int id = 0, maxn;
struct node {
int to;
int cost;
int next;
}edge[max_n];
void addedge(int u, int w, int val) {
node e = {w, val, head[u]};
edge[id] = e;
head[u] = id++;
}
void bfs(int x) {
queue<int> q;
memset(dis, 0, sizeof(dis));
memset(vis, 0, sizeof(vis));
vis[x] = 1;
q.push(x);
id = x, maxn = 0;
while(!q.empty()) {
int u = q.front();
q.pop();
for(int i = head[u]; i != -1; i = edge[i].next) {
if(!vis[edge[i].to] && dis[edge[i].to] < dis[u] + edge[i].cost) {
vis[edge[i].to] = 1;
dis[edge[i].to] = dis[u] + edge[i].cost;
q.push(edge[i].to);
if(dis[edge[i].to] > maxn) {
maxn = dis[edge[i].to];
id = edge[i].to;
}
}
}
}
}
int main() {
int a, b, c;
memset(head, -1, sizeof(head));
memset(edge, 0, sizeof(edge));
while(scanf("%d %d %d", &a, &b, &c) != EOF) { //control+z结束
addedge(a, b, c);
addedge(b, a, c);
}
bfs(1);
bfs(id);
printf("%d\n", maxn);
return 0;
}