poj 2082 Terrible Sets【单调栈】

Terrible Sets

 

 

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.  
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj}  
Again, define set S = {A| A = WH for some W , H ∈ R +  and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.  
Your mission now. What is Max(S)?  
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.  
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n  < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

思路:

生成一个非递减的序列,用栈来维护,在计算面积时,宽始终是栈顶的宽,长是出栈的长的和. 在生成序列过程中,按照计算面积那个思路去出栈,统计最大值.

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;
typedef long long LL;

struct node {
	LL l, w;
}now;

int main() {
	LL n;
	while(scanf("%lld", &n), n != -1) {
		stack<node> s;
		LL ans = 0, temp;
		scanf("%lld %lld", &now.l, &now.w);
		s.push(now);
		for(int i = 0; i < n - 1; i++) {
			scanf("%lld %lld", &now.l, &now.w);
			temp = 0;
			if(now.w >= s.top().w) {
				s.push(now);
				continue;
			}
			while(!s.empty() && s.top().w > now.w) {
				temp += s.top().l;
				if(ans < temp * s.top().w) {
					ans = temp * s.top().w;
				}
				s.pop();
			}
			node next;
			next.l = temp + now.l;
			next.w = now.w;
			s.push(next);
		}
		temp = 0;
		while(!s.empty()) {
			temp += s.top().l;
			if(ans < temp * s.top().w) {
				ans = temp * s.top().w;
			}
			s.pop();
		}
		printf("%lld\n", ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值