Terrible Sets--(单调队列)

Terrible Sets

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 29   Accepted Submission(s) : 16
Problem Description
Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.
 

Input
The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w<sub>1</sub>h<sub>1</sub>+w<sub>2</sub>h<sub>2</sub>+...+w<sub>n</sub>h<sub>n</sub> < 10<sup>9</sup>.
 

Output
Simply output Max(S) in a single line for each case.
 

Sample Input
  
  
3 1 2 3 4 1 2 3 3 4 1 2 3 4 -1
 

Sample Output
  
  
12 14

单调队列常见题目,此题难在题意上题意读懂做就快了,与下面两个题目很像:

1.Largest Submatrix of All 1’s

2.Largest Rectangle in a Histogram

题目就是把以前宽度为1的柱子换为了宽度为w[i]的柱子

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define pi acos(-1.0)
#define inf 0x7fffffff
int n,w[50005],h[50005],q[50005],l[50005],r[50005];
ll sum[50005];
void work()
{
    int i,j,tail=0;
    for(i=1;i<=n;i++)
    {
        while(tail>=1&&h[q[tail]]>=h[i]) tail--;
        if(tail==0) l[i]=1;
        else l[i]=q[tail]+1;
        q[++tail]=i;
    }
    tail=0;
    for(i=n;i>=1;i--)
    {
        while(tail>=1&&h[q[tail]]>=h[i]) tail--;
        if(tail==0) r[i]=n;
        else r[i]=q[tail]-1;
        q[++tail]=i;
    }
    ll cnt=0,temp=0;
    for(i=1;i<=n;i++)
    {
        temp=(sum[r[i]]-sum[l[i]-1])*h[i];
        if(temp>cnt) cnt=temp;
    }
    printf("%I64d\n",cnt);
}
int main()
{
    int i; sum[0]=0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1) break;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&w[i],&h[i]);
            sum[i]=sum[i-1]+w[i];
            r[i]=l[i]=i;
        }
        work();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值