HDU 3974 Assign the task【DFS序+线段树区间染色】

Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.
The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.
Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.
For each test case:
The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.
The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).
The next line contains an integer M (M ≤ 50,000).
The following M lines each contain a message which is either
“C x” which means an inquiry for the current task of employee x
or
“T x y”which means the company assign task y to employee x.
(1<=x<=N,0<=y<=10^9)
Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
Sample Input
1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3
Sample Output
Case #1:
-1
1
2
Source
2011 Multi-University Training Contest 14 - Host by FZU

题意:
给你一棵初始化颜色为-1的多叉树,对子树的根节点进行染x色,那么这棵子树都会被染x色。两种操作,查询时问某个点的颜色,更新时更新子树根节点颜色;
分析·:
利用dfs序的性质,把多叉树处理成一维线性结构,把子树用时间戳标记成一段连续区间,然后用线段树维护区间染色。处理时注意映射关系,bug会很难受的。。。

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cmath>
#include <vector>
using namespace std;
typedef long long LL;

const int MAXN = 5e4 + 5;
int col[MAXN << 2], lazy[MAXN << 2];
int in[MAXN], st[MAXN], ed[MAXN];
vector<int> G[MAXN];
int time;

void init() { //初始化建树
    time = 0;
    for(int i = 0; i < MAXN - 2; i++) {
        G[i].clear();
    }
    memset(col, -1, sizeof(col));
    memset(lazy, -1, sizeof(lazy));
    memset(in, 0, sizeof(in));
}

void dfs(int x) {
    st[x] = ++time; //zzb犯了
    for(int i = 0; i < G[x].size(); i++) {
        int cnt = G[x][i];
        dfs(cnt);
    }
    ed[x] = time;
}

void pushdown(int root) { //标记下推
    if(lazy[root] != -1) {
        lazy[root << 1] = lazy[root];
        lazy[root << 1 | 1] = lazy[root];
        col[root << 1] = lazy[root];
        col[root << 1 | 1] = lazy[root];
        lazy[root] = -1;
    }
}

void updata(int root, int L, int R, int l, int r, int c) { //区间更新
    if(l <= L && R <= r) {
        col[root] = c;
        lazy[root] = c;
        return ;
    }
    pushdown(root);
    int mid = (L + R) >> 1;;
    if(l <= mid) updata(root << 1, L, mid, l, r, c);
    if(r > mid) updata(root << 1 | 1, mid + 1, R, l, r, c);
}

int query(int root, int L, int R, int x) { //单点查询
    //printf("###%d\n", x);
    if(L == R) {
        return col[root];
    }
    int ans = -1;
    pushdown(root);
    int mid = (L + R) >> 1;
    if(x <= mid) ans = query(root << 1, L, mid, x);
    else if(x > mid) ans = query(root << 1 | 1, mid + 1, R, x);
    return ans;
}

int main() {
    int T, n, m, p = 1;
    scanf("%d", &T);
    while(T--) {
        init();
        scanf("%d", &n);
        for(int i = 1; i < n; i++) {
            int x, y;
            scanf("%d %d", &x, &y);
            G[y].push_back(x);
            in[x]++;
        }
        int root;
        for(int i = 1; i <= n; i++) { //query根节点
            if(!in[i]) {
                root = i;
                break;
            }
        }
        dfs(root);
        scanf("%d", &m);
        printf("Case #%d:\n", p++);
        while(m--) {
            char ch;
            int x, c;
            cin >> ch;
            if(ch == 'C') {
                scanf("%d", &x);
                x = st[x];
                printf("%d\n", query(1, 1, n, x));
            }
            else {
                scanf("%d %d", &x, &c);
                int L = st[x];
                int R = ed[x];
                updata(1, 1, n, L, R, c);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值