Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo’s length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题意:
n个数,满足
phi(x)>=y
p
h
i
(
x
)
>=
y
,(x为满足条件的最小值),将x值求和。
分析:
euler打表,1e6~2e6之间一定有个质数,就会满足条件,打表时把MAXN数据开大点就行。
#include <cstdio>
#include <cmath>
typedef long long LL;
const LL MAXN = 1e6 + 1e4;
LL eul[MAXN], p[MAXN];
void init() {
for(LL i = 2; i < MAXN; i++) { //范围放大点,总会遇到一个质数
if(eul[i]) continue;
for(LL j = i; j < MAXN; j += i) {
if(!eul[j]) eul[j] = j;
eul[j] = eul[j] * (i - 1) / i;
}
}
for(LL i = 1; i <= 1e6; i++) {
for(LL j = i; ; j++) {
if(eul[j] >= i) {
p[i] = j;
break;
}
}
}
}
int main() {
init();
LL T, n, t = 1;
scanf("%lld", &T);
while(T--) {
LL sum = 0, k;
scanf("%lld", &n);
for(LL i = 1; i <= n; i++) {
scanf("%lld", &k);
sum += p[k];
}
printf("Case %lld: %lld Xukha\n", t++, sum);
}
return 0;
}