ZOJ 2588 Burning Bridges【无向图求桥并输出对应编号+map处理重边】

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?

Input
The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.

Output
On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

Sample Input
2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output
2
3 7

1
4

题意:给你一个无向图,让你输出桥的数量和升序输出桥的编号;
分析:注意重边了还可以再建边,可以用map标记重边,计算桥时此边要非重边;

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
using namespace std;
typedef long long LL;

const int MAXN = 1e4 + 10;
const int MAXM = 2e5 + 10;
int head[MAXM], low[MAXM], dfn[MAXM], stack[MAXM];
int add_block[MAXM], arr[MAXN];
bool cut[MAXM], instack[MAXM];
int cnt, index_, top, bridge, tt, p;
map<int, int> ma;

struct Edge {
    int to;
    int next;
    int id;
    bool cut_;
}edge[MAXM];

void addedge(int u, int v) {
    edge[cnt].to = v;
    edge[cnt].next = head[u];
    edge[cnt].id = ++tt;
    edge[cnt].cut_ = false;
    head[u] = cnt++;
}

void tarjan(int u, int fa) {
    int v;
    low[u] = dfn[u] = ++index_;
    stack[top++] = u;
    instack[u] = true;
    int son = 0;
    for(int i = head[u]; ~i; i = edge[i].next) {
        v = edge[i].to;
        if(v == fa) continue;
        if(!dfn[v]) {
            son++;
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
            if(low[v] > dfn[u] && ma[u * MAXN + v] == 1) {  //重边不能是桥
                bridge++;
                arr[p++] = (edge[i].id + 1) / 2;
                edge[i].cut_ = true;
                edge[i^1].cut_ = true;
            }
            if(u != fa && low[v] >= dfn[u]) { 
                cut[u] = true;
                add_block[u]++;
            }
        }
        else {
            low[u] = min(dfn[v], low[u]);
        }
    }
    if(u == fa && son > 1) cut[u] = true; 
    if(u == fa) add_block[u] = son - 1; 
    instack[u] = false;
    top--;
}

void init() {
    memset(head, -1, sizeof(head));
    memset(dfn, 0, sizeof(dfn));
    memset(instack, 0, sizeof(instack));
    memset(cut, 0, sizeof(cut));
    memset(arr, 0, sizeof(arr));
    p = tt = cnt = index_ = top = bridge = 0;
    ma.clear();
}

void solve(int n) {
    for(int i = 1; i <= n; ++i) {
        if(!dfn[i]) {
            tarjan(i, i);
        }
    }
    sort(arr, arr + p);
    printf("%d\n", p);
    if(p == 0) { //注意这一点,被坑了好久
        return ;
    }
    for(int i = 0; i < p - 1; ++i) {
        printf("%d ", arr[i]);
    }
    printf("%d\n", arr[p - 1]);
}

int main() {
    int n, m, T;
    scanf("%d", &T);
    while(T--) {
        init();
        scanf("%d %d", &n, &m);
        while(m--) {
            int a, b;
            scanf("%d %d", &a, &b);
            ma[a * MAXN + b]++; //标记重边
            ma[b * MAXN + a]++;
            addedge(a, b);
            addedge(b, a);
        }
        solve(n);
        if(T) printf("\n");
    }
    return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值