搜索进阶------H - Gap

Let’s play a card game called Gap.
You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.

Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: “11” to the top row, “21” to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.

在这里插入图片描述

At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of “42” is “43”, and “27” has no successor.

In the above layout, you can move “43” to the gap at the right of “42”, or “36” to the gap at the right of “35”. If you move “43”, a new gap is generated to the right of “16”. You cannot move any card to the right of a card of value 7, nor to the right of a gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.

在这里插入图片描述

Your task is to find the minimum number of moves to reach the goal layout.
Input
The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.
Output
For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce “-1”.
Sample Input
4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31
Sample Output
0
33
60
-1

就是那个4 * 8的二维数组的状态如何判重,这题真的简单,但是我为甚么想不到用hash呢,我写了个结构体,想用map判重,但是得写比较函数,这怎么写。。。。
还有一个小错误就是空格前一个也可能也是空格,我没判断。。。。。
我的hash方法是就是把二维数组映射成一个数,因为最大是47,所以可以用二进制存储这个二维数组信息。。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define pb push_back
#define mp make_pair
#define fi first
#define se second

map<LL,int>mk;
int x1,y1,x2,y2,x3,y3,x4,y4;
LL ans;

typedef struct Node{
    int a[4][8];
    int t;
    LL sta;
    Node(int b[4][8],int x,LL y){
        for(int i = 0;i < 4;++i)
            for(int j = 0;j < 8;++j)
                a[i][j] = b[i][j];
        t = x;
        sta = y;
    }
}Node;

LL change(int a[4][8])
{
    LL sum = 0;
    for(int i = 0;i < 4;++i)
    {
        for(int j = 0;j < 8;++j)
        {
            //cout << a[i][j] << endl;
            sum += (1LL << (i * 10 + j)) * a[i][j];
        }
    }
    return sum;
}

int bfs(int mm[4][8])
{
    mk.clear();
    queue<Node>que;
    LL x = change(mm);
    mk[x] = 1;
    que.push((Node){mm,0,x});
    while(!que.empty())
    {
        Node tmp = que.front();
        que.pop();
        if(tmp.sta == ans){
            return tmp.t;
        }
        for(int i = 0;i < 4;++i)
        {
            for(int j = 0;j < 8;++j)
            {
                if(!tmp.a[i][j]){
                    if(!tmp.a[i][j - 1] || tmp.a[i][j - 1] % 10 == 7) continue;
                    int num = tmp.a[i][j - 1] + 1;
                    bool flag = false;
                    for(int p = 0;p < 4 && !flag;++p){
                        for(int q = 0;q < 8 && !flag;++q){
                            if(tmp.a[p][q] == num){
                                tmp.a[p][q] = 0;
                                tmp.a[i][j] = num;
                                flag = true;
                                LL y = change(tmp.a);
                                if(!mk[y]){
                                    mk[y] = 1;
                                    que.push((Node){tmp.a,tmp.t + 1,y});
                                }
                                tmp.a[p][q] = num;
                                tmp.a[i][j] = 0;
                            }
                        }
                    }
                }
            }
        }
    }
    return -1;
}


int main()
{
    int t,b[4][8] = {{11,12,13,14,15,16,17,0},
                     {21,22,23,24,25,26,27,0},
                     {31,32,33,34,35,36,37,0},
                     {41,42,43,44,45,46,47,0}};
    ans = change(b);
    scanf("%d",&t);
    while(t--)
    {
        int a[4][8];
        memset(a,0,sizeof(a));
        for(int i = 0;i < 4;++i)
            for(int j = 1;j < 8;++j)
                scanf("%d",&a[i][j]);
        for(int i = 0;i < 4;++i)
        {
            for(int j = 0;j < 8;++j)
            {
                if(a[i][j] == 11) swap(a[0][0],a[i][j]);
                if(a[i][j] == 21) swap(a[1][0],a[i][j]);
                if(a[i][j] == 31) swap(a[2][0],a[i][j]);
                if(a[i][j] == 41) swap(a[3][0],a[i][j]);
            }
        }
        LL x = change(a);
        if(ans == x){
            printf("0\n");
            continue;
        }
        int num = bfs(a);
        printf("%d\n",num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值