pat1151 LCA in a Binary Tree 数据结构

1151 LCA in a Binary Tree (30 分)
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:
6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

不知道为什么,我的一个写法一直过不去,换了一种写法才过,就是找祖先的时候;
其实这道题也没啥说的(详见代码),就是利用深搜回溯找最近公共祖先

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second
const int MAXN = 1e4 + 5;

typedef struct Tree{
    int val;
    struct Tree *left;
    struct Tree *right;
}Tree;

int num1[MAXN];
int num2[MAXN];
map<int,Tree *>mk;
bool flag = false;

Tree* build(int p,int l,int r)
{
    Tree* root = (Tree *)malloc(sizeof(Tree));
    root -> val = num2[p];
    mk[num2[p]] = root;
    int Llen,Rlen;
    int mid;
    for(int i = l;i <= r;++i){
        if(num1[i] == num2[p]){
            Llen = i - l;
            Rlen = r - i;
            mid = i;
            break;
        }
    }
    if(Llen == 0){
        root -> left = NULL;
    }else{
        root -> left = build(p + 1,l,mid - 1);
    }
    if(Rlen == 0){
        root -> right = NULL;
    }else{
        root -> right = build(p + Llen + 1,mid + 1,r);
    }
    return root;
}

Tree* dfs(Tree* root,Tree* a,Tree* b)
{
    if(root == a || root == b || !root)
        return root;
    Tree* l = dfs(root -> left,a,b);
    Tree* r = dfs(root -> right,a,b);
    if(l && r){
        return root;
    }
    if(l) return l;
    if(r) return r;
    return NULL;
}

int main()
{
    int m,n;
    scanf("%d %d",&m,&n);
    for(int i = 1;i <= n;++i){
        scanf("%d",&num1[i]);
    }
    for(int i = 1;i <= n;++i){
        scanf("%d",&num2[i]);
    }
    Tree* root = build(1,1,n);
    while(m--){
        flag = false;
        int a,b;
        scanf("%d %d",&a,&b);
        if(!mk[a] && !mk[b]){
            printf("ERROR: %d and %d are not found.\n",a,b);
        }else if(!mk[a] && mk[b]){
            printf("ERROR: %d is not found.\n",a);
        }else if(mk[a] && !mk[b]){
            printf("ERROR: %d is not found.\n",b);
        }else{
            Tree* tmp = dfs(root,mk[a],mk[b]);
            if(tmp -> val == a || tmp -> val == b){
                if(tmp -> val == a){
                    printf("%d is an ancestor of %d.\n",a,b);
                }else{
                    printf("%d is an ancestor of %d.\n",b,a);
                }
            }else{
                printf("LCA of %d and %d is %d.\n",a,b,tmp -> val);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值